Site Tools


New release available: 2022-07-31 "Igor". upgrade now! [52.2] (what's this?)
docker_awi

Table of Contents

AWI GxFS Admin Server

Docker

reference: https://www.linuxtechi.com/install-docker-and-docker-compose-rocky-linux/

- install rocky linunx 8.6 - dnf update -y - put in docker repository

dnf config-manager --add-repo=https://download.docker.com/linux/centos/docker-ce.repo

- install docker packages

dnf install -y docker-ce

on my base installation there were some complains, which were solved by removing displayed packages beforehand:

yum erase buildah containers-common
 

or alternativly the conflicting packages can be removed by automatic

dnf install docker-ce --allowerasing -y
install docker-compose
curl -L "https://github.com/docker/compose/releases/download/1.29.2/docker-compose-$(uname -s)-$(uname -m)" -o /usr/local/bin/docker-compose
chmod +x /usr/local/bin/docker-compose
docker-compose --version

DRBD

after installation of corosync / pacmeaker / pcsd from the rocky linux repositories DRBD did not work as the according connector did not work poroperly. drbd_utils-9.21.1 were installed along with the rocky installation. Installing drbd_utils-9.21.3 solved the problem. After getting the tar ball for 9.21.3 some additional packages needed to be installed to get the compilation (configure/make/make install) through:

dnf install epel-release
dnf config-manager --set-enabled powertools
dnf install po4a
dnf install clang
dnf install flex
dnf install rpm-build
dnf install dpkg-buildpackage
dnf install build-essential
dnf install g++-7 g++-8 g++-9 g++-10
dnf -y install gcc-c++

After a reboot the correct drbd kernel module is loaded and the nodes are shown correctly with 'pcs status'

docker_awi.txt · Last modified: 2022/07/10 09:40 by 77.6.102.213